Bug Tracker

Opened 10 years ago

Closed 9 years ago

#5826 closed bug (worksforme)

$.POST() AND $.GET() "Type" BUG

Reported by: HexKrak Owned by:
Priority: major Milestone: 1.4.1
Component: ajax Version: 1.4
Keywords: post, get, ajax Cc:
Blocked by: Blocking:

Description

$.post(

'/path/to/action', {key:val, key2:val2}, function(json, status, xml){

alert('test');

}, 'json'

);

Results in the callback function never being called, however; remove the "status" parameter ('json') and the callback function is executed properly.

This appears to be the same issue as ticket #5093, but is verified on 1.4.

Change History (2)

comment:1 Changed 9 years ago by addyosmani

#5093 is a duplicate of this ticket.

comment:2 Changed 9 years ago by snover

Resolution: worksforme
Status: newclosed

live test case works for me. Please reopen this ticket if you can provide a reduced test case.

Note: See TracTickets for help on using tickets.