Bug Tracker

Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#5093 closed bug (duplicate)

$.post() and $.get() XML bug

Reported by: Vadtec Owned by:
Priority: major Milestone: 1.3.2
Component: ajax Version: 1.3.2
Keywords: post, get, xml, ajax Cc:
Blocked by: Blocking:

Description

I am using jQuery 1.3.2 with FireFox 3.5.2 on Windows XP, FireFox 3.0.11 on CentOS 5.3 (Linux 2.6.18-128.2.1.el5 #1 SMP Tue Jul 14 06:39:56 EDT 2009 i686 athlon i386 GNU/Linux) and IE 6 on Windows XP.

I am trying to use the following code:

if ($) {

$(document).ready(

function() {

var my_sid = 12345;

console.log("SID: " + my_sid);

$.post(

'nav_xml.php', {sid: my_sid}, function (xml) {

console.log("entry");

}, 'xml'

);

}

);

}

If I pass data, in FireBug I see the HTTP POST request and response and it works properly, however, the callback function is never called. Thus, in the console log I see:

SID: 12345 HTTP POST & response

If I comment out the data and run the code, in FireBug I see:

SID: 12345 HTTP POST & response entry

After talking to atula in #jquery on freenode, I removed the 'xml' parameter and everything worked just fine in all 3 browsers.

So simply put, having the 'xml' parameter causes the callback to not be called, but removing it allows everything to work just fine.

I have attached the exact jquery source I am working with for reference.

Thanks, Vadtec

Attachments (1)

jquery-1.3.2.js (122.1 KB) - added by Vadtec 10 years ago.
The jQuery 1.3.2 source code I am referencing in my bug report

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by Vadtec

Attachment: jquery-1.3.2.js added

The jQuery 1.3.2 source code I am referencing in my bug report

comment:1 Changed 10 years ago by HexKrak

We just started testing our application in 1.4 and discovered the same issue when passing 'json' as the "type" parameter.

comment:2 Changed 9 years ago by addyosmani

Resolution: duplicate
Status: newclosed

This bug is a duplicate of #5826 which submitted the bug for 1.4.x. As it is newer I'm going to close that one and refer to this if further information is needed.

comment:3 Changed 9 years ago by addyosmani

Duplicate of #5826.

Note: See TracTickets for help on using tickets.