Bug Tracker

Opened 10 years ago

Closed 10 years ago

#5590 closed bug (invalid)

Some selectors not working with namespaces

Reported by: ivokund Owned by: john
Priority: major Milestone: 1.4
Component: selector Version: 1.3.2
Keywords: namespaces, colon Cc:
Blocked by: Blocking:

Description

I tried selecting some elements in an HTML document with namespaces, let's say something like that:

var a = $("<a:b><a:c><a:d>hello</a:d></a:c></a:b>");

Now try to do one of these:

$("a
:c a
:d", a); $("a
:c>a
:d", a); $("a
:c", a).children("a
:d");

Any of them return any elements.

However, this returns an element with correct children:

$("a
:c", a);

And this also works:

$("a
:c", a).find("a
:d");

Change History (1)

comment:1 Changed 10 years ago by dmethvin

Resolution: invalid
Status: newclosed

Please reopen with a complete test case and specify which browsers you've tested. From the description above I am wondering if this is a duplicate of #2901 or at least related.

Note: See TracTickets for help on using tickets.