Bug Tracker

Opened 11 years ago

Closed 9 years ago

Last modified 9 years ago

#2901 closed bug (duplicate)

FF3 changes how getElementsByTagName works for XML namespaces

Reported by: dalangalma Owned by:
Priority: minor Milestone: 1.2.4
Component: core Version: 1.2.3
Keywords: Cc:
Blocked by: Blocking:

Description

Check out https://bugzilla.mozilla.org/show_bug.cgi?id=414612. Basically, in FF2, getElementsByTagName for xml elements with a namespace (like "abc:TheTag") would return those elements if you called getElementsByTagName("TheTag"). In FF3, you get nothing for that call - instead you must call getElementsByTagName("abc:TheTag"), like in IE.

Here's how it affects jQuery: http://brh.numbera.com/experiments/browserdemos/firefox-bug-414612-jquery.html

It used to be that you could get the namespaced xml elements by saying $('TheTag', data), but now there's no way at all to get at those namespaced items.

This is related to jQuery issue #155 and #1826

Change History (2)

comment:1 Changed 9 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Cause is the same as #1826 so I'm closing this as a dup.

comment:2 Changed 9 years ago by dmethvin

Duplicate of #1826.

Note: See TracTickets for help on using tickets.