Bug Tracker

Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#4927 closed bug (invalid)

Wrong ClientX/ClientY calculating in FF < 1.9, Opera > 9.27 and IE

Reported by: netmac Owned by:
Priority: major Milestone: 1.4
Component: event Version: 1.3.2
Keywords: event fix Cc:
Blocked by: Blocking:

Description

If body element have a border or another kind of offset, then we have wrong clientX/clientY calculation.

  • FF with gecko < 1.9 body.offsetLeft/offsetTop don't considered.
  • in IE document.documentElement.clientLeft/clientTop should be subtracted.
  • in Opera > 9.27 with DOCTYPE needs to subtract document.documentElement.clientLeft/clientTop too.

See my fix code in attachment.

Attachments (1)

jquery.event.fix.js (759 bytes) - added by netmac 10 years ago.
event.fix fix

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by netmac

Attachment: jquery.event.fix.js added

event.fix fix

comment:1 Changed 9 years ago by dmethvin

Component: unfiledevent

comment:2 Changed 9 years ago by dmethvin

Related: #4818

comment:3 Changed 9 years ago by miketaylr

Resolution: invalid
Status: newclosed

Closing as invalid. Please reopen with a working testcase. Thanks!

comment:4 Changed 9 years ago by snover

#4818 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.