Bug Tracker

Opened 10 years ago

Closed 9 years ago

Last modified 8 years ago

#4920 closed enhancement (duplicate)

allow using optional data arg to $.getJSON with jsonp callback

Reported by: mmb Owned by:
Priority: minor Milestone: 1.5
Component: ajax Version: 1.3.2
Keywords: ajaxrewrite Cc:
Blocked by: Blocking:

Description

Using the optional data argument to $.getJSON to pass query parameters as an associative array will not work with a jsonp callback because the =? will be encoded to =%3F.

Mailing list discussion at http://groups.google.com/group/jquery-dev/browse_thread/thread/dc8e56c38c8417d8

Attachments (1)

jquery_array_arg_jsonp.patch (515 bytes) - added by mmb 10 years ago.
patch to allow use of data arg to $.getJSON with jsonp callback

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by mmb

patch to allow use of data arg to $.getJSON with jsonp callback

comment:1 Changed 9 years ago by dmethvin

Milestone: 1.41.5
Status: newopen

comment:2 Changed 9 years ago by Rick Waldron

Keywords: ajaxrewrite added

comment:3 Changed 9 years ago by jaubourg

Resolution: duplicate
Status: openclosed

comment:4 Changed 9 years ago by jaubourg

Duplicate of #5812.

Note: See TracTickets for help on using tickets.