Bug Tracker

Opened 10 years ago

Closed 10 years ago

#4844 closed bug (worksforme)

jQuery get textarea text

Reported by: shehriyari Owned by:
Priority: major Milestone: 1.4
Component: build Version: 1.3.2
Keywords: Attributes : val() Cc:
Blocked by: Blocking:

Description

For some reason this line in my code does not work with IE8, whereas it does with everything else [I mean non-IE]:

value = $("FORM TEXTAREA[name='param']").val();

IE8 reports

Attachments (1)

test-4844.html (467 bytes) - added by dmethvin 10 years ago.
Test case for #4844; works in IE8.0.1601.18702

Download all attachments as: .zip

Change History (3)

comment:1 Changed 10 years ago by shehriyari

IE reports "Object does not support this property or method".

I tried to google this case, in general, with textarea - but it seems textareaObject has valid value() method in JScript, so what is the problem?

I tried text() method with the object, but this time all browsers failed to work as intended.

Changed 10 years ago by dmethvin

Attachment: test-4844.html added

Test case for #4844; works in IE8.0.1601.18702

comment:2 Changed 10 years ago by dmethvin

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.