Bug Tracker

Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#4764 closed enhancement (fixed)

Better Last-Modified support and added Etag support

Reported by: lawrencepit Owned by:
Priority: major Milestone: 1.4
Component: ajax Version: 1.3.2
Keywords: Cc:
Blocked by: Blocking:

Description

The Last-Modified code in ajax.js contains a few bugs. This patch solves those. In addition it adds Etag support.

Patch also includes tests. As I didn't know how to include new files in an svn diff I've attached them separately, they need to go in the jquery/test/data directory.

Attachments (3)

etag.diff (3.5 KB) - added by lawrencepit 10 years ago.
if_modified_since.php (331 bytes) - added by lawrencepit 10 years ago.
etag.php (330 bytes) - added by lawrencepit 10 years ago.

Download all attachments as: .zip

Change History (6)

Changed 10 years ago by lawrencepit

Attachment: etag.diff added

Changed 10 years ago by lawrencepit

Attachment: if_modified_since.php added

Changed 10 years ago by lawrencepit

Attachment: etag.php added

comment:1 Changed 10 years ago by john

Component: unfilledajax
Resolution: fixed
Status: newclosed

Great patch! Landed in SVN rev [6388].

comment:2 Changed 10 years ago by john

Landed some Opera-specific code in SVN rev [6432].

comment:3 Changed 9 years ago by snover

#1292 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.