Bug Tracker

Opened 7 years ago

Closed 5 years ago

Last modified 20 months ago

#4598 closed enhancement (worksforme)

Adding capture to allow better event delegation

Reported by: justinbmeyer Owned by:
Priority: low Milestone:
Component: event Version: 1.3.2
Keywords: Event Delegation Cc:
Blocked by: Blocking:

Description

in event.js line 10

from

add: function(elem, types, handler, data) {

to

add: function(elem, types, handler, data, capture) {

AND line 73 from

elem.addEventListener(type, handle, false);

to

elem.addEventListener(type, handle, capture
false);

this is needed for blur / focus (which do not bubble) to work.

Change History (7)

comment:1 Changed 6 years ago by dmethvin

  • Component changed from unfiled to event

comment:2 Changed 5 years ago by dmethvin

#5263 is a duplicate of this ticket.

comment:3 Changed 5 years ago by SlexAxton

  • Milestone changed from 1.4 to 1.5
  • Priority changed from minor to low
  • Status changed from new to open

Thanks Justin. Seems reasonable.

comment:4 follow-up: Changed 5 years ago by john

  • Resolution set to worksforme
  • Status changed from open to closed

I don't think this is needed anymore.

comment:5 in reply to: ↑ 4 ; follow-up: Changed 2 years ago by anonymous

Replying to john:

I don't think this is needed anymore.

Still needed. Attach listeners for capturing phase is the only thing I have to do manually without jQuery... It's SO bad to have different types of event object (jQuery or native) in bubbling and capturing handlers... Please, let capturing live, sometimes it is neccesary.

comment:6 in reply to: ↑ 5 Changed 20 months ago by NemoStein

Replying to anonymous:

Attach listeners for capturing phase is the only thing I have to do manually without jQuery...

Same here. Since it's possible to do this in plain JavaScript, I can't see why we can't have it.

comment:7 Changed 20 months ago by dmethvin

See #14953

Note: See TracTickets for help on using tickets.