Bug Tracker

Opened 11 years ago

Closed 9 years ago

Last modified 8 years ago

#4461 closed enhancement (wontfix)

Support array input into .css to return an object of css properties

Reported by: dantman Owned by:
Priority: major Milestone: 1.4
Component: css Version: 1.3.2
Keywords: Cc:
Blocked by: Blocking:

Description

Discussion: http://groups.google.com/group/jquery-dev/browse_thread/thread/49124146636e5bb1

.css currently supports: .css("name"); => "value" get .css("name", "value"); => jQuery(this) set .css({"name": "value"); => jQuery(this) set

This is an enhancement to support another form of css getting: .css(name?); => {"name":"value"} get

Under this suggestion, when .css() is given a single array as input it will iterate over that array return an object with the array items as keys, and corresponding css values as the values.

In essence: jQuery('<div style="background-color: red; color: white;" />').css(["background-color", "color"]); => { "background-color": "red", "color": "white" }

This enhancement is useful for grabbing multiple css values at once, as well since the output is an object suitable for passing back to .css it is also useful for creating a css object you can use to revert css changes or copy css values from one node to another.

Attachments (1)

css-array-support.patch (581 bytes) - added by dantman 11 years ago.
Patch to add support for the enhancment

Download all attachments as: .zip

Change History (4)

Changed 11 years ago by dantman

Attachment: css-array-support.patch added

Patch to add support for the enhancment

comment:1 Changed 9 years ago by dmethvin

Component: unfiledcss

comment:2 Changed 9 years ago by ajpiano

Resolution: wontfix
Status: newclosed

This could be accomplished by using jQuery.fn.map, and if you need it as part of jQuery.fn.css, you could easily duckpunch it in.

comment:3 Changed 9 years ago by snover

#7169 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.