Bug Tracker

Opened 11 years ago

Closed 9 years ago

Last modified 9 years ago

#4299 closed bug (duplicate)

attr(attrName, newAttrValue) fails on object which has child with name=attrName

Reported by: soswow Owned by: flesler
Priority: major Milestone: 1.4
Component: core Version: 1.4a1
Keywords: Cc:
Blocked by: Blocking:

Description

Sorry, if dublicate, but its strange, that this is not fixed since old versions.

Bug is: When I have form with some inputs with name=action for example, I cant change "action" attribute of this form with "attr" method! As I finded out I cant change any attribute of form when there is same named control inside form.

I don't know what about other attributes of other element if there is control with same name inside it.

This bug applyes only to FF (3 at least) and IE (6 and 7 tested) Safary and Chrome works well.

IE even throw exception in described situation.

A attaching HTML with working example of the bug. You can test it various browsers and You will get different results.

Attachments (2)

jQueryBug.html (1.7 KB) - added by soswow 11 years ago.
Example to Bug #4299
jQueryBug.2.html (2.2 KB) - added by soswow 11 years ago.
Same example with success native DOM working.

Download all attachments as: .zip

Change History (9)

Changed 11 years ago by soswow

Attachment: jQueryBug.html added

Example to Bug #4299

Changed 11 years ago by soswow

Attachment: jQueryBug.2.html added

Same example with success native DOM working.

comment:1 Changed 10 years ago by flesler

Owner: set to flesler

comment:2 Changed 10 years ago by petersendidit

Because you can access form fields via form[fieldName], when the code tried to set the attribute via form[name]=value, it wouldn't work. This was correctly handled when getting form attributes but wasn't handled correctly in setting.

http://github.com/petersendidit/jquery/commit/112eb9c1aa7277c108158d504c6c0ef0f06dbcb8

comment:3 Changed 10 years ago by john

Resolution: fixed
Status: newclosed
Version: 1.3.21.4a1

comment:4 Changed 10 years ago by john

Resolution: fixed
Status: closedreopened

The problem wasn't actually solved, still fails in IE, I backed out the commit.

http://github.com/jquery/jquery/commit/27d65b59f96460987abb84dadc3a75dde8826b3a

comment:5 Changed 9 years ago by masklinn

Isn't this bug a duplicate of #3113 (or the other way around, this one is slightly more general, there's also #1169)?

Also, why comment out the failing test, rather than leave it as a todo mark?

comment:6 Changed 9 years ago by snover

Resolution: duplicate
Status: reopenedclosed

We are rewriting .attr in 1.5 and hopefully can get this dealt with then.

comment:7 Changed 9 years ago by snover

Duplicate of #7472.

Note: See TracTickets for help on using tickets.