Skip to main content

Bug Tracker

Side navigation

#3993 closed bug (worksforme)

Opened January 26, 2009 01:53PM UTC

Closed November 22, 2010 06:02AM UTC

Last modified March 14, 2012 12:00PM UTC

Framesets in Opera not working with jQuery 1.3

Reported by: liwagr Owned by:
Priority: major Milestone: 1.4
Component: selector Version: 1.3.2
Keywords: Cc:
Blocked by: Blocking:

Framesets do not work in Opera when jquery is included in the parent page. Here is a simple test case:


<!DOCTYPE html PUBLIC "-W3CDTD XHTML 1.0 TransitionalEN"




<title>Testing jQuery 1.3</title>

<script type="text/javascript" src="jquery.js"></script>



<frame src="frame.html"></frame>






Hello, I'm in a frame.



This works fine in all browsers except in Opera where all you will get is a blank page (does not even display the contents of frame.html). Removing the <script> tag will make it work. Initial debugging leads me to believe the culprit is within the Sizzler part of jquery-1.3.1.js.

Attachments (0)
Change History (10)

Changed February 23, 2009 02:38PM UTC by StefanB comment:1

still not working in 1.3.2

Changed February 23, 2009 03:13PM UTC by StefanB comment:2

This Bug seems to be sizzle-related. I've postet the report into the sizzle-google-group.

Changed March 17, 2009 08:42PM UTC by john comment:3

component: unfilledselector
resolution: → fixed
status: newclosed

Accidentally landed a fix for this in SVN rev [6275] - but it's all good now.

Changed April 08, 2009 11:45AM UTC by liwagr comment:4

Hi John,

I checked out latest SVN (6306 as of this comment) but the example test case I gave above still doesn't work. I made sure the patch described in the sizzle-google-group link was present.

Changed April 24, 2009 12:46PM UTC by ipa1981 comment:5

resolution: fixed
status: closedreopened

I can confirm that last nightly build (6300 at the moment) still doesn't fix the problem with Opera 10

Changed June 03, 2009 12:27PM UTC by StefanB comment:6

Around line 3038 (build 6300) or line 11 in src/support.js (current svn version (r6351)) this line:

div.innerHTML = ' <link/><table></table><a href="/a" style="color:red;float:left;opacity:.5;">a</a><select><option>text</option></select>';

can be replaced with:

div.innerHTML = ' <link/><a href="/a" style="color:red;float:left;opacity:.5;">a</a>';

then everything works fine BUT the test will be true everytime (because the <table></table> is removed).

Any ideas for another workaround?

Changed June 23, 2009 01:40AM UTC by JohnnyCee comment:7

Any hope of a fix for this issue? I'm holding a release but if one is not forthcoming, I'll have to revert the release version to 1.2.6.

Changed February 16, 2010 11:57AM UTC by sebu comment:8

I confirm this, not working in nightly build of jQuery 1.4.2pre (I can also confirm this error being present in jQuery 1.3.2).

Tested with current Opera 10.10 (Build 6790) on Mac OS X 10.6.2 and Opera 10.10 (unknown build) on Gnu/Linux.

Other reports for this error:

Changed October 26, 2010 06:22PM UTC by miketaylr comment:9

#4217 is a duplicate of this ticket.

Changed November 22, 2010 06:02AM UTC by snover comment:10

resolution: → worksforme
status: reopenedclosed

sebu’s test case works fine for me in the latest version of Opera.