Bug Tracker

Opened 11 years ago

Closed 11 years ago

Last modified 6 years ago

#3636 closed bug (duplicate)

$(document).ready() doesn't wait for CSS to load in Chrome

Reported by: nrabinowitz Owned by:
Priority: major Milestone: 1.3
Component: core Version: 1.2.6
Keywords: chrome ready css Cc: nrabinowitz
Blocked by: Blocking:

Description

This may be the same bug as Ticket #3388 - when using the Google Chrome browser, $(document).ready() doesn't wait for external CSS files to load before firing. This is problematic if you're doing any page manipulation that relies on settings from external CSS files, and it can be difficult to identify and debug, especially on local files where the CSS loads quickly enough to avoid the problem.

Change History (4)

comment:1 Changed 11 years ago by flesler

Cc: nrabinowitz added
need: ReviewTest Case

Ok, can you provide a test case ? a minimalistic html file with the requires html and js to reproduce the problem.

Also, can you post to the jquery-dev group and ask for some feedback ? Please link to this ticket.

comment:2 Changed 11 years ago by dmethvin

Resolution: duplicate
Status: newclosed

This is a duplicate of #1319. Also, document.ready specifies that all css should be defined above scripts.

comment:3 in reply to:  2 Changed 8 years ago by anonymous

Replying to dmethvin:

This is a duplicate of #1319. Also, document.ready specifies that all css should be defined above scripts.

healthy food works well for me

comment:4 Changed 6 years ago by anonymous

Handy piece of info people stumbling across this later might not have:

http://taitems.tumblr.com/post/780814952/document-ready-before-css-ready

using $(window).load waits for all css and images before firing.

Note: See TracTickets for help on using tickets.