Bug Tracker

Opened 11 years ago

Closed 10 years ago

#3259 closed bug (duplicate)

jQuery attr returns unexpected value

Reported by: ben Owned by: flesler
Priority: major Milestone: 1.3
Component: core Version: 1.2.6
Keywords: Cc: ben
Blocked by: Blocking:

Description

$("some_input_element").attr("value") returns the inner HTML of the input element on Internet Explorer (see attached test case). In Firefox 3, it behaves as expected, returning the "value" attribute of the input element.

Please see this link for the thread I started on the jQuery discussion list. It has more details on what I think may be wrong: http://groups.google.com/group/jquery-en/browse_thread/thread/d57e772b6dc94519/a74a39c78c7f58fd?lnk=gst&q=attr#a74a39c78c7f58fd

Attachments (1)

test_ie_attr.html (383 bytes) - added by ben 11 years ago.
HTML test of behavior

Download all attachments as: .zip

Change History (3)

Changed 11 years ago by ben

Attachment: test_ie_attr.html added

HTML test of behavior

comment:1 Changed 11 years ago by flesler

Cc: ben added
Owner: set to flesler
Status: newassigned

comment:2 Changed 10 years ago by dmethvin

Resolution: duplicate
Status: assignedclosed

Duplicate of #1954

Note: See TracTickets for help on using tickets.