Bug Tracker

Opened 12 years ago

Closed 12 years ago

#2321 closed bug (wontfix)

Value of <button> element in IE

Reported by: Anks Owned by:
Priority: minor Milestone: 1.2.4
Component: core Version: 1.2.3
Keywords: Cc:
Blocked by: Blocking:

Description

The val() and attr() functions don't seem to work properly with the <button> element in IE. Instead of returning the value of a button, they return the content. The attached file demonstrates this.

Attachments (1)

button-element-bug.html (656 bytes) - added by Anks 12 years ago.

Download all attachments as: .zip

Change History (3)

Changed 12 years ago by Anks

Attachment: button-element-bug.html added

comment:1 in reply to:  description Changed 12 years ago by Anks

Replying to Anks:

The val() and attr() functions don't seem to work properly with the <button> element in IE. Instead of returning the value of a button, they return the content. The attached file demonstrates this.

Ah, looks like a duplicate of #1954... Sorry, forgot to search for an existing bug before reporting this. Can someone close this bug as well?

comment:2 Changed 12 years ago by brandon

Resolution: wontfix
Status: newclosed

The button elements value is equal to the elements innerText value in IE.

Note: See TracTickets for help on using tickets.