Bug Tracker

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#14878 closed bug (duplicate)

Ajax request not sent error unknown in Firefox

Reported by: Kakao Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.11.0
Keywords: Cc:
Blocked by: Blocking:

Description

When doing this GET synchronous ajax request in Firefox 27.0.1, Fedora 20, jQuery 1.11.0:

$.ajax(ajaxParam).then(
    function (r) {
        html = r.html;
    },
    function (jqXHR) {
        console.log(JSON.stringify([jqXHR, $.ajaxSettings, ajaxParam], null, 4));
    }
);

it works in Chrome 33.0.1750.146 for Linux but in Firefox no request is sent to the server and it errors out:

[
    {
        "readyState": 0,
        "status": 0,
        "statusText": "[Exception... \"<no message>\"  nsresult: \"0x805e0006 (<unknown>)\"  location: \"JS frame :: http://example.com/static/jquery-1.11.0.min.js :: .send :: line 4\"  data: no]"
    },
    {
        "url": "http://example.com/pt/BR",
        "type": "GET",
        "isLocal": false,
        "global": true,
        "processData": true,
        "async": true,
        "contentType": "application/x-www-form-urlencoded; charset=UTF-8",
        "accepts": {
            "*": "*/*",
            "text": "text/plain",
            "html": "text/html",
            "xml": "application/xml, text/xml",
            "json": "application/json, text/javascript",
            "script": "text/javascript, application/javascript, application/ecmascript, application/x-ecmascript"
        },
        "contents": {
            "xml": {},
            "html": {},
            "json": {},
            "script": {}
        },
        "responseFields": {
            "xml": "responseXML",
            "text": "responseText",
            "json": "responseJSON"
        },
        "converters": {
            "text html": true
        },
        "flatOptions": {
            "url": true,
            "context": true
        },
        "jsonp": "callback",
        "cache": false,
        "traditional": true,
        "dataType": "json"
    },
    {
        "url": "/advert/pt/BR",
        "data": {
            "realty_id": "2"
        },
        "async": false,
        "type": "GET"
    }
]

Change History (3)

comment:1 Changed 5 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Duplicate of #14726.
Please ask for help on a forum before filing any other bug reports.

comment:2 in reply to:  1 Changed 5 years ago by Kakao

Replying to dmethvin:

Duplicate of #14726.
Please ask for help on a forum before filing any other bug reports.

That is another bug. The error here is NS_ERROR_CONTENT_BLOCKED

http://james-ross.co.uk/mozilla/misc/nserror?0x805E0006

But I found the cause. It was Adblock Plus blocking the advert world in the url

comment:3 in reply to:  1 Changed 5 years ago by Kakao

Replying to dmethvin:

Duplicate of #14726.
Please ask for help on a forum before filing any other bug reports.

That one is jsonp. This one is not.

Please change to not a bug

Note: See TracTickets for help on using tickets.