Bug Tracker

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#14701 closed bug (fixed)

$.fn.find( jQuery ) broken in 2.1.0pre

Reported by: dcherman Owned by: gibson042
Priority: low Milestone: 2.1
Component: traversing Version: 2.1.0-beta2
Keywords: Cc:
Blocked by: Blocking:

Description

I'm pretty sure this use of $.fn.find is valid, but please let me know if I'm nuts. Not sure exactly how to describe it, so I'll let the test case speak for itself.

http://jsfiddle.net/gsH8z/3/

Change History (5)

comment:1 Changed 5 years ago by dcherman

I meant to put 2.1.0-rc1 in the title. My bad.

comment:2 Changed 5 years ago by gibson042

Owner: set to gibson042
Status: newassigned

I'm not sure why you chose an example with invalid markup, but the issue is valid. Thanks!

comment:3 Changed 5 years ago by Richard Gibson

Resolution: fixed
Status: assignedclosed

Traversing: Check all pairwise element combinations for .find( els )

Ref b8d0d54a3c4960794a1b492957abeb56eddd1e48 Fixes #14701

Changeset: 391c21b15d769fac1c37631b28c0226f57a59796

comment:4 Changed 5 years ago by dmethvin

Component: unfiledtraversing
Priority: undecidedlow
Version: 2.1.0

comment:5 Changed 5 years ago by dmethvin

Milestone: None2.1
Version: 2.1.02.1.0-beta2
Note: See TracTickets for help on using tickets.