Bug Tracker

Opened 6 years ago

Closed 6 years ago

#14626 closed bug (invalid)

Adding empty style attribute to body breaks table layouts

Reported by: kwang1imsa@… Owned by: kwang1imsa@…
Priority: undecided Milestone: None
Component: unfiled Version: 1.10.2
Keywords: Cc:
Blocked by: Blocking:

Description

When body is display:table, the empty style attribute that gets added at the beginning of jQuery's execution breaks layouts. I was implementing this solution:

http://stackoverflow.com/questions/10825879/how-can-a-variable-height-sticky-footer-be-defined-in-pure-css

When I found it. This seems to be a relevant question:

http://stackoverflow.com/questions/17132595/why-does-jquery-2-0-2-add-empty-style-attribute-to-body

Change History (5)

comment:1 Changed 6 years ago by timmywil

#14628 is a duplicate of this ticket.

comment:2 Changed 6 years ago by timmywil

#14627 is a duplicate of this ticket.

comment:3 Changed 6 years ago by timmywil

Owner: set to kwang1imsa@…
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a complete reduced test case on jsFiddle to help us assess your ticket.

Additionally, be sure to test against the "jQuery(edge)" version to ensure the issue still exists—you may need to change this to a specific version depending on the test case.

To get you started, use the appropriate boilerplate:

Open the link and click to "Fork" (in the top menu) to begin.

Also, please read:

Additional resources:

comment:4 Changed 6 years ago by timmywil

#14629 is a duplicate of this ticket.

comment:5 Changed 6 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.