Bug Tracker

Opened 6 years ago

Closed 6 years ago

#14599 closed bug (duplicate)

event.returnValue is deprecated

Reported by: me@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.10.2
Keywords: Cc:
Blocked by: Blocking:

Description

event.returnValue is deprecated. Chrome appears to take this very seriously and will refuse to assign a value to this.originalEvent.

Please do what it says:

event.returnValue is deprecated. Please use the standard event.preventDefault() instead.

Thank you.

Change History (3)

comment:1 Changed 6 years ago by anonymous

I'm sorry, this is a mistake. I thought it was 1.10.2, but it turns out to be 1.5.2. Very sorry.

-Phil

comment:2 Changed 6 years ago by anonymous

I'm sorry, I was mistaken when I thought I was mistaken. It does exists in line 5374 of 1.10.2:

this.isDefaultPrevented = ( src.defaultPrevented
src.returnValue === false

src.getPreventDefault && src.getPreventDefault() ) ? returnTrue : returnFalse;

I've also tried Opera, and it's got the same problem as Chrome.

comment:3 Changed 6 years ago by timmywil

Resolution: duplicate
Status: newclosed

Duplicate of #14282.

Note: See TracTickets for help on using tickets.