Bug Tracker

Opened 6 years ago

Closed 6 years ago

#14538 closed bug (wontfix)

Document Ready doesn't fire ever, after an exception is thrown by a callback

Reported by: jonathan.hoguet@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.7.2
Keywords: Cc:
Blocked by: Blocking:

Description

See the following for an example http://codepen.io/anon/pen/hHEpn

We are working on third party javascript and have one site that our tag never fires document ready in. We then discovered that it is because they have an exception in one of their callbacks.

This was not expected behavior. Is this by design? Is there a work around?

The site we are seeing it in is using 1.7.2 but we are seeing this behavior in 2.0+

Change History (1)

comment:1 Changed 6 years ago by timmywil

Resolution: wontfix
Status: newclosed

Thanks for opening an issue.

This issue has been debated and we decided that it is better than the alternatives. http://bugs.jquery.com/ticket/10251

An uncaught exception is more easily debugged. If it is third party javascript, I suggest opening an issue in their repository.

Note: See TracTickets for help on using tickets.