Skip to main content

Bug Tracker

Side navigation

#14537 closed bug (notabug)

Opened November 13, 2013 08:34PM UTC

Closed November 13, 2013 08:35PM UTC

bug running jQuery on Yahoo Mail (Tampermonkey)

Reported by: Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 2.0.3
Keywords: Cc:
Blocked by: Blocking:

Just referencing the jQuery lib causes an error on Tampermonkey. The script has no code in it, just the @require directive pointing to any version (I tested all from 1.3 and up to the latest 2.03). I tried the "blank" userscript as a Chrome extension to bypass Tampermonkey. Still the same problem.

Here is the console log:

Tampermonkey started

TypeError: Illegal invocation

at Object.<anonymous> (*)

at [as addEventListener] (unknown source), 145:34)

at Function.jQuery.extend.bindReady (unknown source)), 470:11)

at jQuery.fn.jQuery.ready (unknown source)), 282:10)

at jQuery.fn.jQuery.init (unknown source)), 204:22)

at jQuery (unknown source)), 33:10)

at eval (unknown source)), 1524:2)

at eval (unknown source)), 1621:3)

at Object.eval (unknown source)), 9272:3)

at Object.eval (unknown source)), 9290:4)

Interestingly, the Yahoo Plus service does https SSL and maybe that code is different but jQuery works fine there. I run a bunch of sophisticated scripts. They all run clean.

However the basic free Yahoo Mail is unsecure http (at least in the latest version) And that is the one that throws the error. No code can run after that.

Yahoo has been going through a lot of turmoil, so it may be the issue is with them. However, both jQuery and Yahoo are used by a lot of users so I think it is worth looking into it.

Attachments (0)
Change History (1)

Changed November 13, 2013 08:35PM UTC by dmethvin comment:1

resolution: → notabug
status: newclosed

Please report to Tampermonkey.