Bug Tracker

Opened 6 years ago

Closed 6 years ago

#14295 closed bug (duplicate)

$.parseXML() is not working in more version of IE 8

Reported by: anonymous Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.10.2
Keywords: Cc:
Blocked by: Blocking:

Description

I have a issue using $.parseXML() with more version of IE8. Its working absolutely fine in IE8 and chrome as well as Firefox. Please have a look on below given code.

Jquery:

var result = data.d; var obj = decodeBase64(result); var xmlDoc = $.parseXML(obj);

XML returns:

<?xml version="1.0"?>

<ArrayOfMultiLineItemJson xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema

MultiLineItemJson> <Order_Number>PAAAA00017</Order_Number> <Order_Item>01</Order_Item> <Order_Subitem>0001</Order_Subitem> <Order_Type>PO</Order_Type> </MultiLineItemJson> </ArrayOfMultiLineItemJson>

Error message in IE9

Unhandled exception at line 490, column 3 in http://localhost:55005/resources/js/jquery-1.9.0.js

0x800a139e - Microsoft JScript runtime error: Invalid XML:

Change History (1)

comment:1 Changed 6 years ago by timmywil

Resolution: duplicate
Status: newclosed

Duplicate of #14294.

Note: See TracTickets for help on using tickets.