Bug Tracker

Opened 6 years ago

Closed 6 years ago

#14294 closed bug (invalid)

$.parseXML() is not working in more version of IE 8

Reported by: anonymous Owned by: anonymous
Priority: undecided Milestone: None
Component: unfiled Version: 1.10.2
Keywords: Cc:
Blocked by: Blocking:

Description

I have a issue using $.parseXML() with more version of IE8. Its working absolutely fine in IE8 and chrome as well as Firefox. Please have a look on below given code.

Jquery:

var result = data.d;

if (result != "Empty") {

var obj = decodeBase64(result); var xmlDoc = $.parseXML(obj);

} XML returns:

<?xml version="1.0"?>

<ArrayOfMultiLineItemJson xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema

MultiLineItemJson> <Order_Number>PAAAA00017</Order_Number> <Order_Item>01</Order_Item> <Order_Subitem>0001</Order_Subitem> <Order_Type>PO</Order_Type> </MultiLineItemJson> </ArrayOfMultiLineItemJson>

Error message in IE9

Unhandled exception at line 490, column 3:Microsoft JScript runtime error: Invalid XML:

Change History (4)

comment:1 Changed 6 years ago by timmywil

#14296 is a duplicate of this ticket.

comment:2 Changed 6 years ago by timmywil

#14295 is a duplicate of this ticket.

comment:3 Changed 6 years ago by timmywil

Owner: set to anonymous
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a complete reduced test case on jsFiddle to help us assess your ticket.

Additionally, be sure to test against the "jQuery(edge)" version to ensure the issue still exists—you may need to change this to a specific version depending on the test case.

To get you started, use the appropriate boilerplate:

Open the link and click to "Fork" (in the top menu) to begin.

Also, please read:

Additional resources:

comment:4 Changed 6 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.