Bug Tracker

Opened 6 years ago

Closed 6 years ago

#14266 closed bug (invalid)

jquery css interpreter issue in IE8 Standards Mode

Reported by: john.sanford@… Owned by: john.sanford@…
Priority: undecided Milestone: None
Component: unfiled Version: 1.10.2
Keywords: Cc:
Blocked by: Blocking:

Description

Expected behavior: jQuery.css("border-left-width") should report the same way on all browsers.

Actual behavior: jQuery.css("border-left-width") breaks in ie8 Standards mode when there are duplicate css entries.

I noticed that only in ie8 Standards Mode my tables were not resizing properly and after debugging noticed that my css for the table had a duplicate entry. There must be a difference in the way that jquery.<object>.css("border-left-width") responds in ie8 Standards Mode as the following css renders correctly in ie7 and ie9 Standards Modes, but not in ie8 Standard Mode:

table {
 border: 8px solid #C2DDEE;
 border: none;
}

Change History (4)

comment:1 Changed 6 years ago by timmywil

#14267 is a duplicate of this ticket.

comment:2 Changed 6 years ago by timmywil

#14268 is a duplicate of this ticket.

comment:3 Changed 6 years ago by dmethvin

Owner: set to john.sanford@…
Status: newpending

Can you provide a test case that demonstrates the problem and shows what is incorrect? If the border is specified as none then in IE you should always ignore the other values.

comment:4 Changed 6 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.