Bug Tracker

Opened 5 years ago

Closed 5 years ago

#14056 closed bug (duplicate)

problem with offset() and transform scale (CSS)

Reported by: zkizzik@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.10.1
Keywords: Cc:
Blocked by: Blocking:

Description

$(foo).offset().left is not real position, its virtual only.

For example: in the CSS apply transform: scale(0.5); transform-origin: 0 0;

The left position is changed, $(foo).offset().left fails.

i use parseInt($(foo).css('left').replace('px', )) for capture the real position but works only transform-origin: 0 0.

Fix this please.

jQuery UI and draggable function dont work by this bug. http://bugs.jqueryui.com/ticket/6844

Change History (1)

comment:1 Changed 5 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Duplicate of #8362.

Note: See TracTickets for help on using tickets.