Bug Tracker

Opened 6 years ago

Closed 6 years ago

#14039 closed bug (duplicate)

height() and width() inconsistent in IE8 with fractional padding

Reported by: tj.vantoll Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.10.1
Keywords: Cc:
Blocked by: Blocking:

Description

This is from a UI bug and there's a good description of the issue here: http://bugs.jqueryui.com/ticket/9345#comment:6.

Essentially IE8 can return different values for height() and width() when fractional amounts are used for padding: http://jsfiddle.net/akatsuki/wMLNp/.

I'm not sure there's anything we can do about this but I didn't see any previous tickets for this.

Change History (1)

comment:1 Changed 6 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Duplicate of #9628.
We have to stop using offsetHeight and offsetWidth unfortunately and that's a pretty big change.

Note: See TracTickets for help on using tickets.