Bug Tracker

Opened 10 years ago

Closed 10 years ago

#13883 closed bug (duplicate)

ajax request does not complete when clicking a download file in the middle of the request

Reported by: [email protected] Owned by: [email protected]
Priority: undecided Milestone: None
Component: unfiled Version: 2.0.0
Keywords: Cc:
Blocked by: Blocking:

Description

start an ajax request. On server side, take 6 seconds to return the response. Click a link to download a word document. It will download the file while staying on the same webpage. After the 6 seconds $.ajax() does not raise any event. On Fiddler, I see the call completed with status code 200

I can provide a repro

Change History (7)

comment:1 Changed 10 years ago by m_gol

Owner: set to [email protected]
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a complete reduced test case on jsFiddle to help us assess your ticket!

Additionally, be sure to test against the "jQuery 1.x (edge)" or "jQuery 2.x (edge)" version to ensure the issue still exists—you may need to change this to a specific version depending on the test case.

To get you started, use the appropriate boilerplate:

Open the link and click to "Fork" (in the top menu) to begin.

Also, please read:

Additional resources:

Last edited 10 years ago by m_gol (previous) (diff)

comment:2 Changed 10 years ago by [email protected]

Status: pendingnew

comment:3 Changed 10 years ago by m_gol

Status: newpending

This test case is way too big; also, I see no JavaScript files in the test outside of the bundle. What's the actual code?

comment:4 Changed 10 years ago by [email protected]

Status: pendingnew

The code is very simple. First, start ajax request that will take 6 seconds to complete

$.ajax({

type: "POST", url: "Handler1.ashx"

})

Then, user clicks on download link on the page After 10 seconds, this function is executed but none of the events in the ajax call window.setTimeout(function () {

console.log("+ new Date().toTimeString() +? ajax request should have completed");

}, 10000, null);

comment:5 Changed 10 years ago by dmethvin

Resolution: notabug
Status: newclosed

Sorry but it is still not clear. Please ask for help on a forum.

comment:6 Changed 10 years ago by m_gol

Resolution: notabug
Status: closedreopened

comment:7 Changed 10 years ago by m_gol

Resolution: duplicate
Status: reopenedclosed

Duplicate of #13965.

Note: See TracTickets for help on using tickets.