Bug Tracker

Opened 6 years ago

Closed 6 years ago

#13824 closed bug (duplicate)

`text` method is not behaving correctly

Reported by: diofeher@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.9.1
Keywords: Cc:
Blocked by: Blocking:

Description

Just after upgrading to jQuery 1.9.1 a lot of code of my application broke in elements that used .text method.

For example (inspector console):

  • $('#extend_project_link').text('test')

    <a href="#" class="button" id="extend_project_link">[object Text]</a>

Instead of placing the text in the element, [object Text] is added instead. My pull request address this issue: https://github.com/jquery/jquery/pull/1256

Change History (1)

comment:1 Changed 6 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Duplicate of #13823.

Note: See TracTickets for help on using tickets.