Bug Tracker

Opened 6 years ago

Closed 6 years ago

#13823 closed bug (invalid)

`text` method is not behaving correctly

Reported by: diofeher@… Owned by: diofeher@…
Priority: undecided Milestone: None
Component: unfiled Version: 1.9.1
Keywords: Cc:
Blocked by: Blocking:

Description

Just after upgrading to jQuery 1.9.1 a lot of code of my application broke in elements that used .text method.

For example (inspector console):

  • $('#extend_project_link').text('test')

    <a href="#" class="button" id="extend_project_link">[object Text]</a>

Instead of placing the text in the element, [object Text] is added instead. My pull request address this issue: https://github.com/jquery/jquery/pull/1256

Change History (3)

comment:1 Changed 6 years ago by dmethvin

Owner: set to diofeher@…
Status: newpending

This seems to work fine for me. http://jsfiddle.net/hfuV6/

Can you provide a test case that includes only jQuery core? I suspect the problem is in a plugin or other code.

comment:2 Changed 6 years ago by dmethvin

#13824 is a duplicate of this ticket.

comment:3 Changed 6 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.