Bug Tracker

Opened 6 years ago

Closed 6 years ago

#13370 closed bug (duplicate)

FadeIn/SlideDown/Show are not run if 'display' is not 'none'

Reported by: Didjo Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.9.0
Keywords: Cc:
Blocked by: Blocking:

Description

When applying a fadeOut on a div for 500ms, but – after 300ms – apply a fadeIn :

  • if a stop(1,1) is called before fadeIn, the div will fadeIn back to opacity 100%.
  • but if a stop(1,0) is called, fadeIn fail (surely because div is already display:block when called), but it should fade to opacity 100%, or we could be at least able to force it.

See example here : http://jsfiddle.net/Didjo/4v8Uk/ Discussion here : http://stackoverflow.com/questions/14633382/jquery-stop1-1-launches-next-animation-but-not-stop1-0

Change History (2)

comment:1 Changed 6 years ago by dmethvin

Status: newopen

Corrected repro: http://jsfiddle.net/dmethvin/4v8Uk/18/

Please don't pass invalid arguments to .stop(), it takes two Booleans.

comment:2 Changed 6 years ago by dmethvin

Resolution: duplicate
Status: openclosed

Duplicate of #13483.

Note: See TracTickets for help on using tickets.