Bug Tracker

Opened 7 years ago

Closed 7 years ago

#13121 closed bug (duplicate)

AJAX setRequestHeader not adding header for soapaction

Reported by: anonymous Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.8.3
Keywords: Cc:
Blocked by: Blocking:

Description

When executing a $.ajax call a custom header of "soapaction" does not get added to the HTTP Header in the request, however when I override the existing "Accept-Language" header, the overridden value is displayed. I've also tested this with version 1.7.1 with the same result.

Browsers tested: Firefox 17.0.1, Chrome 23.0.1271.101

Code with failure to add header: beforeSend: function(xhr) {

xhr.setRequestHeader("soapaction","/CatalogService/UpdateCatalogEndpoint");

}

Code with a successfully augmented header: beforeSend: function(xhr) {

xhr.setRequestHeader("Accept-Language", "en-US");

}

Change History (1)

comment:1 Changed 7 years ago by ajpiano

Resolution: duplicate
Status: newclosed

Duplicate of #13120.

Note: See TracTickets for help on using tickets.