Bug Tracker

Opened 9 years ago

Closed 9 years ago

#12331 closed bug (duplicate)

$el.on('click') breaks if adding to parent multiple times

Reported by: dan.schumann@… Owned by: dan.schumann@…
Priority: undecided Milestone: None
Component: unfiled Version: 1.8.0
Keywords: Cc:
Blocked by: Blocking:

Description

http://jsfiddle.net/9VThz/

if you add an element to a parent multiple times, it breaks any $el.on() bindings

Change History (4)

comment:1 Changed 9 years ago by gibson042

Owner: set to dan.schumann@…
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a complete reduced test case on jsFiddle to help us assess your ticket.

Additionally, be sure to test against the jQuery Edge version to ensure the issue still exists. To get you started, use this boilerplate: http://jsfiddle.net/FrKyN/ Open the link and click to "Fork" (in the top menu) to get started.

Version 0, edited 9 years ago by gibson042 (next)

comment:2 Changed 9 years ago by dan.schumann@…

Status: pendingnew

http://jsfiddle.net/9VThz/2/

the first fiddle wasn't complete

comment:3 Changed 9 years ago by anonymous

http://jsfiddle.net/9VThz/3/

this is one with new jquery version

comment:4 Changed 9 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Duplicate of #12330.

Note: See TracTickets for help on using tickets.