Bug Tracker

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#12330 closed bug (invalid)

adding element to parent twice destroys .on(

Reported by: dan.schumann@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.7.1
Keywords: Cc:
Blocked by: Blocking:

Description

Hello

I have an $el using backbone

and it has a parent $('#app').html( $el ); works fine, and keeps events and anything that is $el.on('change', '.child-class', fct); it breaks though, if I do $('#app').html( $el ); $('#app').html( $el ); (twice) Why is this? Each time I'm referencing a jquery element or an html element

Change History (3)

comment:1 Changed 7 years ago by timmywil

Resolution: invalid
Status: newclosed

Thanks for taking the time to contribute to the jQuery project!

Please ask for support on the forums or the #jquery irc channel. If you mean to report a bug in jQuery core, please provide a complete reduced test case from http://jsFiddle.net or http://jsbin.com using the git("edge") version of jQuery to help us assess your ticket.

comment:2 Changed 7 years ago by dmethvin

Adding the same element to its current position removes data and events. It's an abuse/misunderstanding of .html() in any case.

http://tbranyen.com/post/missing-jquery-events-while-rendering

comment:3 Changed 7 years ago by dmethvin

#12331 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.