Bug Tracker

Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#12272 closed bug (duplicate)

`$tr.show()` uses `display: block` in Chrome

Reported by: anonymous Owned by:
Priority: undecided Milestone: None
Component: css Version: 1.8.0
Keywords: Cc:
Blocked by: Blocking:

Description

In Chrome, when using body { display: -webkit-flex }, a tr element gets a default display of block. This causes ALL trs in a document to show with display: block because jQuery appends a test tr to the body so as to get the default display value.

A tr with display: block causes weird rendering and issues such as colspan not being respected.

Fiddle: http://jsfiddle.net/aZRUW/

Change History (5)

comment:1 Changed 7 years ago by anonymous

Appending a tr to a table/tbody instead might be an appropriate solution. Appending a tr to body is illegal, after all.

comment:2 Changed 7 years ago by gibson042

Component: unfiledcss
Resolution: duplicate
Status: newclosed

Duplicate of #10416.

comment:3 Changed 7 years ago by anonymous

No, this happens on Chrome, not Firefox. It has a completely different cause (-webkit-flex isn't even supported on Firefox).

comment:4 Changed 7 years ago by Rick Waldron

Related: #8099

Protip: don't override the default display, use a class instead.

comment:5 Changed 6 years ago by anonymous

This bug should be reopened. It is still ocurring in chrome. The th element gets by default display: block on show()

Note: See TracTickets for help on using tickets.