Bug Tracker

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#12019 closed bug (duplicate)

Calling next() on an element without any next sibling throws

Reported by: phistuck Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.8b1
Keywords: Cc:
Blocked by: Blocking:

Description

Test case - $("body").next();

Throws (in Chrome 20) - TypeError: Cannot read property 'nodeType' of null

Works silently (returns an empty set) in 1.7.2.

Change History (3)

comment:1 Changed 7 years ago by dmethvin

Resolution: duplicate
Status: newclosed

No test case provided, but seems like a dup.

comment:2 Changed 7 years ago by dmethvin

Duplicate of #11969.

comment:3 Changed 7 years ago by phistuck

Sorry for the duplication. Note that I did provide a test case.

Note: See TracTickets for help on using tickets.