Bug Tracker

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#11842 closed bug (duplicate)

using find(with selectos and filter :not(with some selectors) )

Reported by: biavatipaolo@… Owned by: biavatipaolo@…
Priority: high Milestone: None
Component: selector Version: 1.7.2
Keywords: Cc:
Blocked by: Blocking:

Description

this instruction works (only one selector in :not filter)

ie: $('#menuStato > li > a').find('+ ul > li:not(.toggleMenuActions)')

when i use the :not filter with two or more class selector inside separated by ',' on a selector that start with '+' in a find function

the result is an empty array

ie: $('#menuStato > li > a').find('+ ul > li:not(.toggleMenuActions, .toggleMenuFooter, .nascosto)')

The same instruction written like the follow works... (i just moved the ' > a ' from the fist brackets to the second one

ie: $('#menuStato > li').find(' > a + ul > li:not(.toggleMenuActions, .toggleMenuFooter, .nascosto)')

Change History (5)

comment:1 Changed 7 years ago by sindresorhus

Owner: set to biavatipaolo@…
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a complete reduced test case on jsFiddle to help us assess your ticket.

Additionally, be sure to test against the jQuery Edge version to ensure the issue still exists. To get you started, use this boilerplate: http://jsfiddle.net/FrKyN/ Open the link and click to "Fork" (in the top menu) to get started.

comment:2 Changed 7 years ago by biavatipaolo@…

Status: pendingnew

I made a jsFiddle example test

http://jsfiddle.net/XHjqL/1/

comment:3 Changed 7 years ago by gnarf

Status: newopen

Positional selectors and find() have been known to play weirdness before... This has a test case now though, we'll see what the selectors guys have to say about it.

comment:4 Changed 7 years ago by timmywil

Component: unfiledselector
Priority: undecidedhigh
Resolution: duplicate
Status: openclosed

comment:5 Changed 7 years ago by timmywil

Duplicate of #11814.

Note: See TracTickets for help on using tickets.