Bug Tracker

Opened 7 years ago

Closed 7 years ago

#11457 closed bug (fixed)

Another slideToggle jump effect

Reported by: anonymous Owned by: gnarf
Priority: low Milestone: 1.8
Component: css Version: 1.7.1
Keywords: Cc:
Blocked by: Blocking:

Description

A div contains a UL with LIs floated left and with percentage widths. When slideToggle shows the div, sometimes there's a jump at the end of the animation.

This jsfiddle has 12 examples demonstrating the effect.

Giving the UL a width removes the jump, possibly making this a duplicate of #8370 and #9513. And the behavior is similar to #10662.

But it appears if the LI widths add up to 100%, the animation is smooth, which can be seen in the first and second examples.

And when the LI widths don't add up to 100%, there's a jump at the end of the animation.

And confounding things further, in the 10th example, the LI widths do add up to 100% yet there's a jump at the end of the animation.

This inconsistency in behavior may indicate a bug.

Change History (14)

comment:1 Changed 7 years ago by Rick Waldron

Component: unfiledcss
Milestone: None1.8
Owner: set to gnarf
Priority: undecidedlow
Status: newassigned

@gnarf can you take a look at this?

comment:2 Changed 7 years ago by mikesherov

Resolution: worksforme
Status: assignedclosed

This is working on edge: http://jsfiddle.net/r5L6U/1/

All hail the great, mysterious effects rewrite!

comment:3 Changed 7 years ago by scottgonzalez

If it only works in edge shouldn't that be fixed and not worksforme?

comment:4 Changed 7 years ago by mikesherov

Resolution: worksforme
Status: closedreopened

I suppose. I had seen a few times where we close as WFM when we don't know what fixed it, just that it now works. I can change to just fixed.

comment:5 Changed 7 years ago by mikesherov

Resolution: fixed
Status: reopenedclosed

comment:6 Changed 7 years ago by gnarf

I'd like to try to figure out what was broken at least and write a unit for the fact that we fixed it....

comment:7 Changed 7 years ago by mikesherov

feel free to reopen and write a test. I was just trying to triage open tixx. I seem to have failed :-\

comment:8 Changed 7 years ago by gnarf

Resolution: fixed
Status: closedreopened

Nah - it definitely closed now, but I'm going to reopen because we don't have a unit covering it, and I want to make sure we can't regress on this one, whatever magic it was that fixed it...

comment:9 Changed 7 years ago by dmethvin

Status: reopenedopen

comment:10 Changed 7 years ago by mikesherov

Owner: changed from gnarf to mikesherov
Status: openassigned

comment:11 Changed 7 years ago by dmethvin

Milestone: 1.8None

comment:12 Changed 7 years ago by mikesherov

Milestone: None1.8
Owner: changed from mikesherov to gnarf37

gnarf, I haven't found a good way to test this. I'm inclined to just close as fixed. If you'd like to tackle it, please do, other resolve as fixed.

comment:13 Changed 7 years ago by mikesherov

Owner: changed from gnarf37 to gnarf

comment:14 Changed 7 years ago by gnarf

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.