Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#11188 closed bug (wontfix)

Problem with .animate() for opacity in IE8

Reported by: San4es Owned by:
Priority: low Milestone: None
Component: css Version: 1.7
Keywords: ie8 Cc:
Blocked by: Blocking:

Description

If I use .animate({ opacity: 0.32 }), nothing happens in IE8, but there is no such problem in other browsers (Chrome, Safari, Firefox, Opera, IE7, IE9).

There is example: http://jsfiddle.net/ZVdaq/13/

Change History (5)

comment:1 Changed 8 years ago by sindresorhus

Simplified testcase

Looks like the problem occurs without jQuery too, so it's definitely not a jQuery bug. IE8 opacity filter does not want to apply to child elements with position set. I you add "filter: inherit" on the child CSS, the filter applies.

A fix would be to set "filter: inherit" on all descendants that has position set, but that would probably be an massive performance bottleneck. If there are no other solutions for this, I think we should just document it somewhere.

comment:2 Changed 8 years ago by addyosmani

Component: unfiledcss
Keywords: needsdocs added
Priority: undecidedlow
Resolution: wontfix
Status: newclosed

So..granted that this isn't directly a jQuery bug, I think Sindre is right in that the most we should probably consider doing is documenting this. We *could* normalize the behaviour so that it behaves as expected in the test case above, but I'm tempted to second the notion that filter:inherit could be a perf issue. Unless someone feels strongly that this should be fixed, closing.

comment:3 Changed 8 years ago by dmethvin

Keywords: ie8 added

comment:4 Changed 7 years ago by dmethvin

Keywords: needsdocs removed

The first page of Google search is full of solutions on this, and it's a pretty specific edge case. I'll let Google handle it.

comment:5 Changed 7 years ago by mikesherov

#9349 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.