Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#11172 closed bug (duplicate)

Wouldn't it be great if when() could accept an array?

Reported by: chrispaterson82@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.7.1
Keywords: Cc:
Blocked by: Blocking:

Description

Right now if I have a list (array) of Deferreds I have to call

.when.apply(this, myArray).always(/* do something */);

it would be nice if the when function first checked for an array. So you could pass:

.when(myArray).always(/* do something */);

Change History (5)

comment:1 Changed 8 years ago by Rick Waldron

Resolution: duplicate
Status: newclosed

comment:2 Changed 8 years ago by Rick Waldron

Duplicate of #10367.

comment:3 Changed 8 years ago by Rick Waldron

Resolution: duplicate
Status: closedreopened

comment:4 Changed 8 years ago by Rick Waldron

Resolution: duplicate
Status: reopenedclosed

comment:5 Changed 8 years ago by Rick Waldron

Duplicate of #8256.

Note: See TracTickets for help on using tickets.