Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#10367 closed enhancement (duplicate)

Allow passing an array of promises to jQuery.when

Reported by: jdc0589@… Owned by:
Priority: low Milestone: None
Component: deferred Version: 1.6.4
Keywords: Cc:
Blocked by: Blocking:

Description

It would be convenient if passing an array of promises as the first argument to jQuery.when behaved the same as passing multiple promises as separate parameters.

I know this can be achieved by simple calling jQuery.when.apply(null, [...] , but it would be nice if it wasn't necessary.

Change History (7)

comment:1 Changed 8 years ago by ajpiano

Resolution: duplicate
Status: newclosed

comment:2 Changed 8 years ago by ajpiano

Duplicate of #10307.

comment:3 Changed 8 years ago by Rick Waldron

Resolution: duplicate
Status: closedreopened

comment:4 Changed 8 years ago by Rick Waldron

Resolution: duplicate
Status: reopenedclosed

comment:5 Changed 8 years ago by Rick Waldron

Duplicate of #8256.

comment:6 Changed 8 years ago by Rick Waldron

Component: unfileddeferred
Priority: undecidedlow

comment:7 Changed 8 years ago by Rick Waldron

#11172 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.