Bug Tracker

Opened 6 years ago

Closed 6 years ago

#10983 closed bug (worksforme)

.show() not firing on id when .hide() used on class in IE7/8

Reported by: miketwalker86@… Owned by:
Priority: low Milestone: None
Component: effects Version: 1.7.1
Keywords: Cc:
Blocked by: Blocking:

Description

When doing a hide() operation on a class followed by a .show() on an id that contains that class, IE7/8 seem to be playing catch-up with the events and briefly showing the id before the hide hits it iterating through the class objects. For example, if using a speed you will see the item begin to appear then hide after a very brief time. I haven't seen this problem appear in other browsers and it definitely seems to be an order of operation thing since it consistently will briefly appear before being hidden.

I've tried using callbacks from hide() on the class and then firing show() on the id, but that seems to break things overall. I'm wondering if the issue may just be the callbacks breaking. I am using version 1.7.1 of JQuery.

Change History (2)

comment:1 Changed 6 years ago by dcherman

Thanks for taking the time to contribute to the jQuery project! Please provide a complete reduced test case on jsFiddle to help us assess your ticket.

Additionally, be sure to test against the jQuery Edge version to ensure the issue still exists. To get you started, use this boilerplate: http://jsfiddle.net/FrKyN/ Open the link and click to "Fork" (in the top menu) to get started.

comment:2 Changed 6 years ago by addyosmani

Component: unfiledeffects
Priority: undecidedlow
Resolution: worksforme
Status: newclosed

Based on the information you've supplied, I've put together a test case that attempts to reproduce the issue you've described. Testing three different scenarios (no specific speed supplied, a set speed and callbacks), I haven't been able to obtain the same issues in IE that you're experiencing with 1.7.1. http://jsfiddle.net/pNHDB/. Depending on the speeds being used, there may well be a brief moment when you can see the initial element with class/ID, but also consider most animations you're running are probably being executed on DOM/page load which may also be playing a factor.

I'll be closing this ticket as works for me, but if someone else can reproduce the issue, please feel free to reopen.

Note: See TracTickets for help on using tickets.