Bug Tracker

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#10918 closed bug (duplicate)

fadeIn/show a table row will add style='display: block' to the tr tag (only in firefox)

Reported by: zcheny@… Owned by:
Priority: low Milestone: None
Component: effects Version: 1.7.1
Keywords: Cc:
Blocked by: Blocking:


This is may a duplicate of http://bugs.jquery.com/ticket/8629, fadeIn(or show) a table row will add "style='display: block'" to the tr tag which messed up the table. It's only repro in firefox with jquery 1.5 to 1.7. IE is correct, and jquery 1.4.1 is also ok.

I have created a very simple example to duplicate the issue. http://jsfiddle.net/7NyUK/

Change History (4)

comment:1 Changed 4 years ago by sindresorhus

  • Component changed from unfiled to effects
  • Priority changed from undecided to low
  • Status changed from new to open

I can reproduce this in Firefox 8, not in Chrome 15.

You can easily fix this in Firefox by placing .hide() after .insertAfter(), but that's only a temp fix.

Since it works correctly in Chrome, but not in Firefox, this should be fixed.

comment:2 Changed 4 years ago by jmaresco@…

I second this comment. I don't understand how using .hide() is a fix. I want to show, not hide the element.

I tried using .hide().fadeIn() but the display: block element is still there.

I've seen multiple versions of this ticket but this seems to be one of the only open ones.

comment:4 Changed 4 years ago by mikesherov

  • Resolution set to duplicate
  • Status changed from open to closed

comment:5 Changed 4 years ago by mikesherov

Duplicate of #10416.

Note: See TracTickets for help on using tickets.