Bug Tracker

Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#10848 closed bug (fixed)

Animation toggling loses state tracking in certain atomic edge cases

Reported by: timmywil Owned by: timmywil
Priority: blocker Milestone: 1.7.2
Component: effects Version: 1.7.1rc1
Keywords: Cc:
Blocked by: Blocking:

Description

ajpiano and I figured out that there are certain times you can click or focus/blur and a new inaccurate state seems to get applied at some point.

http://jsfiddle.net/timmywil/F5sTJ/3/

Change History (4)

comment:1 Changed 5 years ago by timmywil

  • Component changed from unfiled to effects
  • Milestone changed from None to 1.7.2
  • Owner set to timmywil
  • Priority changed from undecided to blocker
  • Status changed from new to assigned

comment:2 Changed 5 years ago by Youri

This is not event-specific, but rather an animation problem. Documentation of the .stop() method claims this issue to be fixed as of jQuery 1.7, but the fiddle clearly shows that this is not the case.

Youri

comment:3 Changed 5 years ago by timmywil

  • Resolution set to fixed
  • Status changed from assigned to closed

When stopping a show, save showing end state instead of start state to fix animation toggling issue. Fixes #10848.

Changeset: e8673ae1aafe16a8a7f855958f545c710bf8133e

comment:4 Changed 5 years ago by timmywil

#11222 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.