Bug Tracker

Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#10517 closed bug (fixed)

.before() and .after() give unexpected return type

Reported by: anonymous Owned by:
Priority: low Milestone: 1.next
Component: manipulation Version: 1.7b2
Keywords: Cc:
Blocked by: Blocking:

Description

As seen at: http://jsfiddle.net/beL4x/ (Spot the odd one out...)

The return value of .before() and .after() is affected when the object is created in a particular way. It is also affected by previous uses of the object as an argument to a function.

Change History (3)

comment:1 Changed 8 years ago by timmywil

Component: unfiledmanipulation
Milestone: None1.next
Priority: undecidedlow
Status: newopen

comment:2 Changed 7 years ago by Uri Gilad

Resolution: fixed
Status: openclosed

Fix #10517. before() and after() on disconnected node should return multiple nodes. Closes gh-851.

Changeset: f843a7062fef5a262c244575712b8173ced7c1a2

comment:3 Changed 7 years ago by dmethvin

#8759 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.