Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#10496 closed bug (duplicate)

$.attr doesn't work, in on click handler it keeps attribute old value after overriding its value

Reported by: pajoe@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.6.4
Keywords: Cc:
Blocked by: Blocking:

Description

$(".imgBox").append("<input id='tt' type='checkbox' />");
$(".imgBox input").click(function(){
    if ($(this).attr("checked"))
        $(this).attr("checked", "checked");
    else
        $(this).attr("checked", null);
});

Change History (2)

comment:1 Changed 8 years ago by dmethvin

Resolution: duplicate
Status: newclosed

comment:2 Changed 8 years ago by dmethvin

Duplicate of #10434.

Note: See TracTickets for help on using tickets.