Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#10434 closed bug (duplicate)

checkbox checked bug

Reported by: taila Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.6.4
Keywords: Cc:
Blocked by: Blocking:

Description

since 1.6.3

$('#checkbox').attr("checked", true);

#checkbox is checked.

click #checkbox, then #checkbox is unchecked.

But that #checkbox OnClick Events

var checked = $('#checkbox').attr("checked");

checked == "checked"

Change History (3)

comment:1 Changed 8 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Use .prop() for getting the dynamic state of a checkbox, or use $('#checkbox')[0].checked.

comment:2 Changed 8 years ago by dmethvin

Duplicate of #10278.

comment:3 Changed 8 years ago by dmethvin

#10496 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.