Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#10390 closed bug (invalid)

Object does not support property or method getAttributeNode

Reported by: vruzin@… Owned by: vruzin@…
Priority: low Milestone: None
Component: core Version: 1.6.4
Keywords: Cc:
Blocked by: Blocking:

Description

SCRIPT438: Object does not support property or method "getAttributeNode" jquery-1.6.4.js, Line 2479 Symbol 4

IE7

not work in IE6/IE7 In older versions of jQuery - it work

I see in with working with opacity and fadeIn/fadeOut I dont know with other functions...

Change History (9)

comment:1 Changed 8 years ago by Rick Waldron

Owner: set to vruzin@…
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a complete reduced test case on jsFiddle to help us assess your ticket!

Additionally, be sure to test against the jQuery Edge version to ensure the issue still exists. To get you started, use this boilerplate: http://jsfiddle.net/FrKyN/ Open the link and click to "Fork" (in the top menu) to get started.

comment:2 Changed 8 years ago by sp00n

I have the same issue, both in IE9 emulating IE7 on Win7 x64 and in a virtual box IE7 on Windows XP.

The code block in question:

// IE6/7 do not support getting/setting some attributes with get/setAttribute
if ( !jQuery.support.getSetAttribute ) {
	
	// Use this for any attribute in IE6/7
	// This fixes almost every IE6/7 issue
	nodeHook = jQuery.valHooks.button = {
		get: function( elem, name ) {
			var ret;
			ret = elem.getAttributeNode( name );
			// Return undefined if nodeValue is empty string
			return ret && ret.nodeValue !== "" ?
				ret.nodeValue :
				undefined;
		},

It happens when I do a ele.fadeIn().fadeOut(). I've tried to change it to fadeTo(), fadeToggle() or animate({"opacity": 0}) to no avail, same error. A plain .hide() works.

Adding show(), stop(), delay() or whatnot inbetween doesn't help either, as doesn't using setTimeout in the callback function instead of delay().

I've temporarily fixed the issue by wrapping a

if (elem.innerHTML != undefined) {

around the get: method, however this seems rather clunky to me.

comment:3 Changed 8 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

comment:4 Changed 8 years ago by greg@…

i am getting this as well. Working in IE9, but in developer tools, i set Doucument Mode to IE.Standard

I do a simple $('#chTagsAllSpan').fadeIn() on page load and i get this error

comment:5 Changed 8 years ago by Rick Waldron

#10788 is a duplicate of this ticket.

comment:6 Changed 8 years ago by Rick Waldron

Resolution: invalid
Status: closedreopened

comment:7 Changed 8 years ago by Rick Waldron

Component: unfiledcore
Priority: undecidedlow
Status: reopenedpending

@greg

Please provide a complete reduced test case on jsFiddle - thanks. http://jsfiddle.net/FrKyN/ Open the link and click to "Fork" (in the top menu) to get started.

comment:8 Changed 8 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

comment:10 Changed 8 years ago by dyblast@…

I have the same issue.

In the following example

HTML:

		<div id="dialog" title="title">
			<object type="application/..."> 
			</object>
		</div>

JS:

$('#dialog').dialog()
Note: See TracTickets for help on using tickets.