Bug Tracker

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#10384 closed bug (duplicate)

webkit browser throws exception on fadeIn and fadeOut (fix)

Reported by: poulbak Owned by:
Priority: high Milestone: None
Component: effects Version: 1.6.4
Keywords: Cc:
Blocked by: Blocking:

Description

I know this is a dublicate of 'Ticket #5145'. I can't reopen it :-(

My phone (a webkit clone) throws an error on FadeIn() and fadeOut(). That's because it returns 'false' for '$.support.opacity'. Then it triggers the IE only 'cssHooks.opacity' and chunks on 'style.removeAttribute'. The real problem is that when setting style.opacity to '.55' and then read it, it says: '0,550000011920929' (note the comma and the rounding error).

Now if I simply add this to my code:

        jQuery.support.opacity = true;
        jQuery.cssHooks.opacity = undefined;

everything is fine, fadeIn() works like show() and fadeOut() works like hide() - a lot better than an error.

So, basically we need to change the test for 'support.opacity', so it includes the above value, but still excludes old IE. Line 1221 currently says:

		opacity: /^0.55$/.test( a.style.opacity ),

By removing the '$' sign it should work:

		opacity: /^0.55/.test( a.style.opacity ),

Change History (5)

comment:1 Changed 10 years ago by Rick Waldron

Component: unfiledeffects
Priority: undecidedhigh
Resolution: duplicate
Status: newclosed

You don't need to be able to "reopen" a ticket just to draw attention. Simply commenting will suffice. Filing duplicates just creates unnec. work

comment:2 Changed 10 years ago by Rick Waldron

#10384 is a duplicate of this ticket.

comment:3 Changed 10 years ago by Rick Waldron

Duplicate of #10384.

comment:4 Changed 10 years ago by poulbak

Ok, I will try to get attention without 'reopening'. On other bug systems, tickets, that are closed with 'fixed' status won't be reopened, but that's apparently not how this one works.

Actually this is not a duplicate of #5145, my mistake, it's just related. #5145 does not mention the rounding error, which is the real issue here!

The proposed change still stands!

comment:5 Changed 10 years ago by Rick Waldron

Ticket still closed, deferring to original issue that shares _root_ problem.

Note: See TracTickets for help on using tickets.