Bug Tracker

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#10351 closed bug (duplicate)

$('#xxoo').removeAttr('disabled');

Reported by: Jimmy Owned by: Jimmy
Priority: low Milestone: None
Component: attributes Version: 1.6.2
Keywords: Cc:
Blocked by: Blocking:

Description

Today I meet a problem in jQuery Library 1.6.2. The function removeAttr('disabled') does not work. Follow me and I will show how I find it.

  1. I make a button in the HTML page,and make is attribute disabled='disabled'
  2. I use the function: $('#xxoo').removeAttr('disabled')
  3. Then I find that, this button can trigger its function, but the appearance of the button looks like a button with the disabled='disable'
  4. Last I use the JavaScript phrase. I find the button normal.

I'm so sorry my English is poor! If I can not express my idea please contact me to

812219625@…

or

kaka13932535308@…

Change History (7)

comment:1 Changed 10 years ago by 812219625@…

Please contact me if anyone knows that

comment:2 Changed 10 years ago by kaka13932535308@…

Please contact me if anyone knows that

comment:3 Changed 10 years ago by addyosmani

Component: unfiledattributes
Owner: set to Jimmy
Priority: undecidedlow
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a complete reduced test case on jsFiddle to help us assess your ticket!

Additionally, be sure to test against the jQuery Edge version to ensure the issue still exists. To get you started, use this boilerplate: http://jsfiddle.net/FrKyN/

Open the link and click to "Fork" (in the top menu) to get started.

comment:4 Changed 10 years ago by dmethvin

Resolution: duplicate
Status: pendingclosed

comment:5 Changed 10 years ago by dmethvin

Duplicate of #9719.

comment:6 Changed 10 years ago by diopralinato

if you are using jquery 1.6+, you must use this:

$('#xxoo').prop('disabled',false);

comment:7 Changed 10 years ago by timmywil

1.6.1+ allows the use of attr again, but prop is recommended.

Note: See TracTickets for help on using tickets.