Bug Tracker

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#10145 closed bug (duplicate)

.live() different behavior than .bind() with disabled element

Reported by: Dave Stein <[email protected]…> Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.6.2
Keywords: Cc:
Blocked by: Blocking:

Description

I have three fiddles to accurately show this problem.

1.4.4 working with live http://jsfiddle.net/davestein/ENHfv/ 1.6.2 working with bind http://jsfiddle.net/davestein/e4Nnh/ 1.6.2 NOT working with live http://jsfiddle.net/davestein/t6mHw/

Change History (2)

comment:1 Changed 10 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Browsers don't treat this case consistently, see the duplicate ticket and the one referenced there. We can't force the browser to fire native events in these cases so we normalized it to not fire on disabled elements.

comment:2 Changed 10 years ago by dmethvin

Duplicate of #8389.

Note: See TracTickets for help on using tickets.